Excelboy: Excel Formeln,Tipps & Tricks

Month: März 2014

SVERWEIS">Ex­cel For­mel SVERWEIS

Wie finde ich ei­nen Wert für ein Kri­te­rium aus ei­ner Ex­cel Ta­belle in ei­ner an­de­ren Tabelle?

Ex­cel For­mel SVERWEIS

Die Ex­cel For­mel SVERWEIS ist ge­nau DIE Ex­cel For­mel, die das Le­ben und Ar­bei­ten mit Ex­cel enorm er­leich­tert. Der Grund da­für ist, dass man Da­ten oft aus meh­re­ren un­ter­schied­li­chen Quel­len be­kommt, und die dann zu­sam­men­füh­ren muss.

Ex­cel For­mel:

=SVERWEIS(Kriterium; Be­reich; Spalte; Verweis)

Die Funk­tion SVERWEIS sucht das Kri­te­rium in dem Be­reich (in der 1.Spalte) und gibt den da­zu­ge­hö­ri­gen Wert aus der Spalte (In­dex) des Be­rei­ches zu­rück. Der Pa­ra­me­ter Ver­weis be­stimmt, ob eine un­ge­fähre (WAHR bzw. 1) oder eine ge­naue Über­ein­stim­mung (FALSE bzw. 0) ge­sucht wird.

SVERWEIS Bei­spiel „DVD Kollektion“

Herr Huhn möchte ei­nige DVDs aus sei­ner Kol­lek­tion (Ta­belle 1) ver­kau­fen. Er holt sich ein An­ge­bot von ei­nem Händ­ler (Ta­belle 2; nach Preis ab­stei­gend sor­tiert) ein. Mit Hilfe von der SVERWEIS Funk­tion ord­net Herr Huhn die Ver­kaufs­preise zu, um über die Zweck­mä­ßig­keit des Ver­kaufs ent­schei­den zu können.

Excel Formel SVERWEIS

Ex­cel For­mel (Bsp. Zelle E3):

=SVERWEIS(A3;$I$3:$J$12;2;0)

We­gen der Sor­tie­rung war eine di­rekte Über­tra­gung der Preise in die Ex­cel Tabelle_1 un­mög­lich. Die Ex­cel SVERWEIS For­mel hat die Zu­ord­nung per­fekt gemeistert;)

SVERWEIS im Bei­spiel wurde so kon­stru­iert, dass es mög­lich war, die Ex­cel For­mel in die erste Zelle (F3) zu schrei­ben und dann die For­mel für an­dere Zel­len „run­ter­zu­zie­hen“. Da­bei musste man den Be­reich ent­we­der „fi­xie­ren“ (F4) oder „be­nen­nen“ (sh. un­ten) – sonst ver­schie­ben sich die Ver­weise zu­sam­men mit der Formel.

Ex­cel Top Tipps:

1)      um eine fal­sche Zu­ord­nung für die SVERWEIS zu ver­mei­den emp­fehle ich den Be­reich, in dem ge­sucht wird, sinn­voll zu be­nen­nen. Für das Bei­spiel wird der Be­reich I3:J12 mar­kiert und als „preis“ benannt:

Excel Formel SVERWEIS

Jetzt kön­nen wir die Ex­cel For­mel SVERWEIS so umformulieren:

=SVERWEIS(A3; preis;2;0)

Da­mit wird die For­mel auch übersichtlicher.

2)      Wenn die Ex­cel For­mel SVERWEIS ein Kri­te­rium im Be­reich nicht fin­det, lie­fert die den Wert „#NV“ zu­rück. In die­sem Fall wird z.B. das Auf­sum­mie­ren der Er­geb­nisse (sh. Funk­tion SUMME) nicht mög­lich. Als eine Lö­sung kommt die Ex­cel Funk­tion WENNFEHLER in Frage.

Excel Formeln

ANZAHL">Ex­cel For­mel ANZAHL

Wie zähle ich die Zel­len mit In­hal­ten in Excel?

Ex­cel For­mel ANZAHL

Mit Hilfe von der Ex­cel For­mel ANZAHL wer­den Zel­len mit Zah­len oder vor­ge­ge­bene Werte zusammengezählt.

Ex­cel For­mel:

=ANZAHL(Zellen,[Werte])

Die ANZAHL For­mel kann ent­we­der stan­dard­ge­mäß, oder mit der  Funk­tion aus dem „Start“ oder im „For­meln“ Be­reich in Ex­cel auf­ge­ru­fen werden.

Um alle nicht leere Zel­len zu zäh­len, wird die Funk­tion ANZAHL2 verwendet.

Ex­cel For­mel:

=ANZAHL2(Zellen,[Werte])

ANZAHL Bei­spiel „Lager“

Der Fa­ci­lity Ma­na­ger – Herr So­ko­low­ski – muss über­prü­fen, wel­che Ar­ti­kel auf La­ger noch vor­han­den sind. In der Ta­belle wird ent­we­der die Menge für die vor­han­de­nen Ar­ti­kel oder „#NV“ angezeigt.

Excel Formel Anzahl

Ex­cel For­meln (Bsp. Zel­len B9 und B10):

=ANZAHL(B2:B8)

=ANZAHL2(B2:B8)

Es sind 5 Ar­ti­kel (ANZAHL) von 7 (ANZAHL2) vor­han­den.

Die Er­geb­nisse für die mar­kier­ten Zel­len wer­den au­ßer­dem in der Sta­tus­leiste rechts un­ten angezeigt:

Excel Formel Anzahl 2

Ex­cel Top Tipp:

fürs Zäh­len von den Zel­len, de­ren In­halte be­stimm­ten Kri­te­rien ent­spre­chen, wird die Funk­tion ZÄHLENWENN verwendet.

Excel Formeln

TAG,MONAT,JAHR">Ex­cel For­meln TAG,MONAT,JAHR

Wie be­komme ich eine fort­lau­fende Zahl für den Tag (Mo­nat, Jahr) aus dem be­stimm­ten Da­tum in Excel?

Ex­cel For­meln TAG,MONAT,JAHR

Die Ex­cel For­meln TAG, MONAT, JAHR ge­ben den Tag, Mo­nat oder das Jahr ei­nes Da­tums als eine fort­lau­fende Zahl zurück.

Ex­cel For­meln:

=TAG(Da­tum)

=MONAT(Da­tum)

=JAHR(Da­tum)

TAG,MONAT,JAHR Bei­spiel „durch­schnitt­li­cher Umsatz“

Die Tank­stel­len­be­sit­ze­rin – Frau Schmedt – will den durch­schnitt­li­chen Um­satz Ih­rer Tank­stelle pro Tag be­rech­nen. Am 28.11.2013 be­trug der Ge­samt­satz im No­vem­ber 1.200€- Mit Hilfe der TAG For­mel wird die An­zahl von ver­gan­ge­nen Ta­gen ermittelt.

Excel Formel TAG

Die Tank­stelle brachte im No­vem­ber durch­schnitt­lich 43€ pro Tag.

Die Er­geb­nisse von den Ex­cel For­meln =MONAT(B2) und =JAHR(B2):

Excel Formeln TAG,MONAT,JAHR

Ex­cel Top Tipp:

Ex­cel For­meln TAG, MONAT, JAHR sind u.a. für eine Pro­gno­se­rech­nung sehr hilf­reich. Um die Be­rech­nung für das obige Bei­spiel dy­na­mi­scher ge­stal­ten zu kön­nen, wird die Ver­wen­dung von der Ex­cel For­mel HEUTE zu­sam­men mit der TAG Funk­tion (=TAG(HEUTE())) emp­foh­len.

Excel Formeln

ZÄHLENWENN">Ex­cel For­mel ZÄHLENWENN

Wie kann ich die An­zahl von Zel­len mit be­stimm­ten In­hal­ten in Ex­cel herausfinden?

Ex­cel For­mel ZÄHLENWENN

Die Ex­cel For­mel ZÄHLENWENN zählt nur die Zel­len mit In­hal­ten nach vor­ge­ge­be­nen Kri­te­rien aus ei­nem Bereich.

Ex­cel For­mel:

=ZÄHLENWENN(Bereich, Kri­te­rium)

ZÄHLENWENN Bei­spiel „Kühe & Schweine“

Der Bauer – Herr Rich­ter – hat Kühe und Schweine auf sei­nem Bau­ern­hof. Er will her­aus­fin­den, wie viele Kühe und wie viele Schweine un­ter­wegs und au­ßer­dem – wie viele Tiere drei Jahre oder äl­ter sind.

Excel Formel ZÄHLENWENN

Ex­cel For­mel (Bsp. Zelle B12):

=ZÄHLENWENN(B2:B11;“=Kuh“)

Herr Rich­ter hat 4 Kühe und 6 Schweine, da­von sind 4 Tiere drei Jahr alt oder älter.

Ex­cel Top Tipp:

die Funk­tion ANZAHL zählt alle Zel­len mit Zah­len und ANZAHL2 – nicht leere Zellen.

Excel Formeln

HEUTE">Ex­cel For­mel HEUTE

Wie be­stimme ich das Da­tum von Heute in Excel?

Ex­cel For­mel HEUTE

Mit Hilfe von der Ex­cel For­mel HEUTE be­kom­men wir die fort­lau­fende Zahl des heu­ti­gen Da­tums zurück.

Die Funk­tion HEUTE() ist eine der we­ni­gen Ex­cel Funk­tio­nen, die keine Ar­gu­mente hat.

Ex­cel For­mel:

=HEUTE()

Am 04.01.2014 wäre die Zahl 41643. Ex­cel passt das Zel­len­for­mat au­to­ma­tisch an und lie­fert 04.01.2014 zurück.

HEUTE Bei­spiel „Urlaub“

Herr Meier war­tet un­ge­dul­dig auf sei­nen Ur­laub – am 04.08.2014 fliegt er für zwei Wo­chen auf Fu­er­teven­tura. Er ruft je­den Tag eine Excel-Datei mit den fol­gen­den For­meln auf:

Excel Formel HEUTE

Am 04.01.2014 hat Herr Meier noch 212 Tage bis zu sei­nem Ur­laub. Am 05.01.2014 wer­den es nur noch 211 Tage usw.

Ex­cel Top Tipp:

Ex­cel For­mel HEUTE() ist eine „dy­na­mi­sche“ Funk­tion — das Er­geb­nis än­dert sich täg­lich. Man sollte „In­halte ein­fü­gen…“ ver­wen­den, um das heu­tige Da­tum zu fixieren.

Oft ist es sinn­voll, die Ex­cel For­mel HEUTE mit den Funk­tio­nen TAG, MONAT, JAHR zu verwenden.

Excel Formeln

SUMME">Ex­cel For­mel SUMME

Wie bilde ich in Ex­cel eine Summe?

Ex­cel For­mel SUMME

Mit Hilfe von der Ex­cel For­mel SUMME wer­den alle an­ge­ge­be­nen Zah­len addiert.

Ex­cel For­mel:

=SUMME(Zahl1, Zahl2,…Zahl-n)

Die SUMME Funk­tion kann ent­we­der stan­dard­ge­mäß, oder mit dem Knopf    Summe1  aus dem „Start“ oder „For­meln“ Be­reich in Ex­cel auf­ge­ru­fen werden.

Au­ßer­dem wird die Summe von den mar­kier­ten Zel­len in der Sta­tus­leiste rechts un­ten angezeigt:

Summe2

SUMME Bei­spiel „Kiosk“

Die Ki­osk­be­sit­ze­rin – Frau Berg – möchte gern den Ta­ges­um­satz Ih­res Ki­osks be­rech­nen. Am Ki­osk wer­den Ar­ti­kel aus drei Ka­te­go­rien – Presse, Snacks und Ge­tränke – ver­kauft. Frau Berg be­rech­net mit Hilfe von der SUMME Funk­tion den Ge­samt­um­satz und den Um­satz pro Kategorie:

Excel Formel SUMME

Ex­cel For­mel (Bsp. Zelle B9):

=SUMME(B2:B8)

Die Ar­gu­mente der SUMME für den Ge­samt­um­satz be­fin­den sich im Be­reich B2:B8. Das Er­geb­nis be­kommt man auch, wenn die „Au­to­summe“ Funk­tion in der Zelle B9 auf­ge­ru­fen wird.

Für die Ka­te­go­rien wer­den die re­le­van­ten Zel­len (Ar­gu­mente) für die SUMME ein­zeln ausgewählt.

Ex­cel Top Tipp:

Die Ex­cel For­mel =SUMME(Zahl1, Zahl2,…Zahl-n) be­rück­sich­tigt nur Zah­len als Argumente.

Im Fall:

Summe4

wird der Text „aus­ver­kauft“ in der Zelle B8 von der Ex­cel For­mel SUMME nicht berücksichtigt.

Ent­hält ein Ar­gu­ment ei­nen Feh­ler, lie­fert die Ex­cel Funk­tion SUMME() auch ei­nen Feh­ler zurück.

Summe5

In sol­chen Fäl­len ist es sinn­voll die SUMME Funk­tion zu­sam­men mit der Ex­cel Funk­tion WENNFEHLER zu nutzen.

Excel Formeln

Copyright © 2020 Excelboy: Excel Formeln,Tipps & Tricks

Theme by Anders NorenUp ↑